We are continuing to monitor for any further issues.
Posted Mar 21, 2023 - 20:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2023 - 19:39 UTC
Investigating
Overall Description of the issue and Affected Services: Our Email campaigns feature experienced an issue causing some campaigns to fail, but all failed campaigns have been successfully delivered without any data loss.
Start time: March 21, 2023 - 17:30 [UTC].
End Time: March 21, 2023 - 19:30 [UTC].
Business Impact: We experienced an issue with our Email campaigns feature, causing some campaigns to fail. However, we are pleased to inform you that our R&D team has successfully resolved the issue, and all previously failed campaigns have been delivered.
If you did retry sending any affected campaigns during the time the incident occurred, please be aware that only one of the retry attempts was sent.
We apologize for any inconvenience caused and thank you for your patience. We understand the criticality of this situation and did everything possible to minimize the impact on your business.
If you have any questions or concerns, please feel free to reach out to our customer support team.